CVE-2017-5946

NameCVE-2017-5946
DescriptionThe Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory traversal vulnerability. If a site allows uploading of .zip files, an attacker can upload a malicious file that uses "../" pathname substrings to write arbitrary files to the filesystem.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-846-1, DSA-3801-1
NVD severityhigh (attack range: remote)
Debian Bugs856269

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libzip-ruby (PTS)wheezy0.9.4-1vulnerable
wheezy (security)0.9.4-1+deb7u1fixed
ruby-zip (PTS)jessie (security), jessie1.1.6-1+deb8u1fixed
stretch1.2.0-1.1fixed
buster, sid1.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libzip-rubysource(unstable)(unfixed)high
libzip-rubysourcewheezy0.9.4-1+deb7u1highDLA-846-1
ruby-zipsource(unstable)1.2.0-1.1high856269
ruby-zipsourcejessie1.1.6-1+deb8u1highDSA-3801-1

Notes

https://github.com/rubyzip/rubyzip/issues/315

Search for package or bug name: Reporting problems