CVE-2017-5969

NameCVE-2017-5969
Descriptionnull pointer dereference when parsing a xml file using recover mode
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
Debian Bugs855001

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5vulnerable
wheezy (security)2.8.0+dfsg1-7+wheezy7vulnerable
jessie (security), jessie2.9.1+dfsg1-5+deb8u4vulnerable
stretch, sid2.9.4+dfsg1-2.2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)(unfixed)855001

Notes

[stretch] - libxml2 <no-dsa> (Minor issue, only a denial-of-service when using recover mode)
[jessie] - libxml2 <no-dsa> (Minor issue, only a denial-of-service when using recover mode)
[wheezy] - libxml2 <no-dsa> (Minor issue, only a denial-of-service when using recover mode)
http://www.openwall.com/lists/oss-security/2016/11/05/3
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=778519

Search for package or bug name: Reporting problems