CVE-2017-5975

NameCVE-2017-5975
DescriptionHeap-based buffer overflow in the __zzip_get64 function in fetch.c in zziplib 0.13.62 allows remote attackers to cause a denial of service (crash) via a crafted ZIP file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-994-1, DSA-3878-1
NVD severitymedium
Debian Bugs854727

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zziplib (PTS)jessie0.13.62-3+deb8u1fixed
jessie (security)0.13.62-3+deb8u2fixed
stretch0.13.62-3.2~deb9u1fixed
bullseye, sid, buster0.13.62-3.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zziplibsource(unstable)0.13.62-3.1854727
zziplibsourcejessie0.13.62-3+deb8u1DSA-3878-1
zziplibsourcewheezy0.13.56-1.1+deb7u1DLA-994-1

Notes

http://blogs.gentoo.org/ago/2017/02/09/zziplib-heap-based-buffer-overflow-in-__zzip_get64-fetch-c/
https://github.com/gdraheim/zziplib/commit/33d6e9c52fcf1a8983896a512033994dc2ca5734 (v0.13.63)
https://github.com/gdraheim/zziplib/commit/64e745f8a3604ba1c444febed86b5e142ce03dd7 (v0.13.63)

Search for package or bug name: Reporting problems