CVE-2017-5987

NameCVE-2017-5987
DescriptionThe sdhci_sdma_transfer_multi_blocks function in hw/sd/sdhci.c in QEMU (aka Quick Emulator) allows local OS guest privileged users to cause a denial of service (infinite loop and QEMU process crash) via vectors involving the transfer mode register during multi block transfer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1497-1
NVD severitylow (attack range: local)
Debian Bugs855159

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u7fixed
stretch (security), stretch1:2.8+dfsg-6+deb9u4fixed
buster, sid1:2.12+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.8+dfsg-3low855159
qemusourcejessie1:2.1+dfsg-12+deb8u7lowDLA-1497-1
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(unfixed)low
qemu-kvmsourcewheezy(not affected)

Notes

[wheezy] - qemu <not-affected> (Vulnerable code not present)
[wheezy] - qemu-kvm <not-affected> (Vulnerable code not present)
https://lists.gnu.org/archive/html/qemu-devel/2017-02/msg02776.html

Search for package or bug name: Reporting problems