CVE-2017-5992

NameCVE-2017-5992
DescriptionOpenpyxl 2.4.1 resolves external entities by default, which allows remote attackers to conduct XXE attacks via a crafted .xlsx document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs854442

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openpyxl (PTS)jessie1.7.0+ds1-1fixed
stretch2.3.0-3fixed
buster, sid2.4.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openpyxlsource(unstable)2.3.0-3medium854442
openpyxlsourcejessie(not affected)
openpyxlsourcewheezy(not affected)

Notes

[jessie] - openpyxl <not-affected> (vulnerable code not present)
[wheezy] - openpyxl <not-affected> (vulnerable code not present)
http://www.openwall.com/lists/oss-security/2017/02/07/5
https://bitbucket.org/openpyxl/openpyxl/issues/749
https://bitbucket.org/openpyxl/openpyxl/commits/3b4905f428e1

Search for package or bug name: Reporting problems