CVE-2017-6196

NameCVE-2017-6196
DescriptionMultiple use-after-free vulnerabilities in the gx_image_enum_begin function in base/gxipixel.c in Ghostscript before ecceafe3abba2714ef9b432035fe0739d9b1a283 allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PostScript document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)stretch9.26a~dfsg-0+deb9u6fixed
stretch (security)9.26a~dfsg-0+deb9u7fixed
buster9.27~dfsg-2+deb10u3fixed
buster (security)9.27~dfsg-2+deb10u4fixed
bullseye9.52.1~dfsg-1fixed
sid9.53.1~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)(not affected)

Notes

- ghostscript <not-affected> (Issue introduced later, cf. bug #856142)
https://bugs.ghostscript.com/show_bug.cgi?id=697596
Fixed by: https://git.ghostscript.com/?p=ghostpdl.git;h=ecceafe3abba2714ef9b432035fe0739d9b1a283
Possibly introduced only after https://git.ghostscript.com/?p=ghostpdl.git;h=cffb5712bc10c2c2f46adf311fc74aaae74cb784

Search for package or bug name: Reporting problems