CVE-2017-6362

NameCVE-2017-6362
DescriptionDouble free vulnerability in the gdImagePngPtr function in libgd2 before 2.2.5 allows remote attackers to cause a denial of service via vectors related to a palette with no colors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1106-1, DSA-3961-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2vulnerable
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9vulnerable
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.5-1medium
libgd2sourcejessie2.1.0-5+deb8u11mediumDSA-3961-1
libgd2sourcestretch2.2.4-2+deb9u2mediumDSA-3961-1
libgd2sourcewheezy2.0.36~rc1~dfsg-6.1+deb7u10mediumDLA-1106-1

Notes

https://github.com/libgd/libgd/issues/381
https://github.com/libgd/libgd/commit/56ce6ef068b954ad28379e83cca04feefc51320c

Search for package or bug name: Reporting problems