CVE-2017-6363

NameCVE-2017-6363
Description** DISPUTED ** In the GD Graphics Library (aka LibGD) through 2.2.5, there is a heap-based buffer over-read in tiffWriter in gd_tiff.c. NOTE: the vendor says "In my opinion this issue should not have a CVE, since the GD and GD2 formats are documented to be 'obsolete, and should only be used for development and testing purposes.'"
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)stretch2.2.4-2+deb9u5vulnerable
stretch (security)2.2.4-2+deb9u4vulnerable
buster2.2.5-5.2vulnerable
bullseye, sid2.3.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.3.0-1

Notes

[buster] - libgd2 <no-dsa> (Minor issue)
[stretch] - libgd2 <no-dsa> (Minor issue)
[jessie] - libgd2 <ignored> (Minor issue)
https://github.com/libgd/libgd/commit/0be86e1926939a98afbd2f3a23c673dfc4df2a7c
https://github.com/libgd/libgd/commit/2dbd8f6e66b73ed43d9b81a45350922b80f75397
https://github.com/libgd/libgd/issues/383

Search for package or bug name: Reporting problems