CVE-2017-6384

NameCVE-2017-6384
DescriptionMemory leak in the login_user function in saslserv/main.c in saslserv/main.so in Atheme 7.2.7 allows a remote unauthenticated attacker to consume memory and cause a denial of service. This is fixed in 7.2.8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs855588

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
atheme-services (PTS)stretch7.2.9-1fixed
bullseye, sid, buster7.2.9-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
atheme-servicessourcejessie(not affected)
atheme-servicessource(unstable)7.2.9-1855588

Notes

[jessie] - atheme-services <not-affected> (versions prior to 7.2.7 not vulnerable)
7.2.7 vulnerable, fixed in 7.2.8, but the fix introduced another DOS, fixed in 7.2.9
(Possibly) introduced in https://github.com/atheme/atheme/commit/8ac7aa8d007331ae694f099c288e27f911e8cad1 (v7.2.7)

Search for package or bug name: Reporting problems