CVE-2017-6439

NameCVE-2017-6439
DescriptionHeap-based buffer overflow in the parse_string_node function in bplist.c in libimobiledevice libplist 1.12 allows local users to cause a denial of service (out-of-bounds write) via a crafted plist file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2168-1, DLA-870-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libplist (PTS)buster2.0.1~git20190104.3f96731-1fixed
bookworm, sid, bullseye2.2.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libplistsourcewheezy1.8-1+deb7u3DLA-870-1
libplistsourcejessie1.11-3+deb8u1DLA-2168-1
libplistsource(unstable)1.12+git+1+e37ca00-0.1

Notes

https://github.com/libimobiledevice/libplist/issues/95
https://github.com/libimobiledevice/libplist/commit/32ee5213fe64f1e10ec76c1ee861ee6f233120dd

Search for package or bug name: Reporting problems