CVE-2017-6503

NameCVE-2017-6503
DescriptionWebUI in qBittorrent before 3.3.11 did not escape many values, which could potentially lead to XSS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-897-1
NVD severitymedium (attack range: remote)
Debian Bugs856977

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qbittorrent (PTS)wheezy2.9.8-1vulnerable
wheezy (security)2.9.8-1+deb7u1fixed
jessie3.1.10-1vulnerable
stretch, buster, sid3.3.7-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qbittorrentsource(unstable)3.3.7-3low856977
qbittorrentsourcewheezy2.9.8-1+deb7u1mediumDLA-897-1

Notes

[jessie] - qbittorrent <no-dsa> (Minor issue)
https://github.com/qbittorrent/qBittorrent/commit/6ca3e4f094da0a0017cb2d483ec1db6176bb0b16
Fixed upstream in 3.3.11

Search for package or bug name: Reporting problems