CVE-2017-6508

NameCVE-2017-6508
DescriptionCRLF injection vulnerability in the url_parse function in url.c in Wget through 1.19.1 allows remote attackers to inject arbitrary HTTP headers via CRLF sequences in the host subcomponent of a URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-851-1
NVD severitymedium (attack range: remote)
Debian Bugs857073

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wget (PTS)jessie1.16-1+deb8u5fixed
jessie (security)1.16-1+deb8u6fixed
stretch (security), stretch1.18-5+deb9u3fixed
buster1.20.1-1.1fixed
bullseye, sid1.20.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wgetsource(unstable)1.19.1-2medium857073
wgetsourcebuster1.18-5medium
wgetsourcejessie1.16-1+deb8u2medium
wgetsourcestretch1.18-5medium
wgetsourcewheezy1.13.4-3+deb7u4mediumDLA-851-1

Notes

http://lists.gnu.org/archive/html/bug-wget/2017-03/msg00018.html
http://git.savannah.gnu.org/cgit/wget.git/commit/?id=4d729e322fae359a1aefaafec1144764a54e8ad4

Search for package or bug name: Reporting problems