CVE-2017-6799

NameCVE-2017-6799
DescriptionA cross-site scripting (XSS) vulnerability in view_filters_page.php in MantisBT before 2.2.1 allows remote attackers to inject arbitrary JavaScript via the 'view_type' parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mantis (PTS)wheezy1.2.18-1vulnerable
wheezy (security)1.2.18-1+deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mantissource(unstable)(not affected)
mantissourcewheezy(unfixed)end-of-life

Notes

- mantis <not-affected> (Vulnerable versions only 2.1.0 through 2.2.0)
[wheezy] - mantis <end-of-life> (Unsupported in Wheezy LTS)
https://github.com/mantisbt/mantisbt/commit/1677251434b6e8b2be8f1d4376a3e78f7be14d95
http://www.mantisbt.org/bugs/view.php?id=22497

Search for package or bug name: Reporting problems