CVE-2017-6815

NameCVE-2017-6815
DescriptionIn WordPress before 4.7.3 (wp-includes/pluggable.php), control characters can trick redirect URL validation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-860-1, DSA-3815-1
NVD severitymedium (attack range: remote)
Debian Bugs857026

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10vulnerable
wheezy (security)3.6.1+dfsg-1~deb7u19fixed
jessie (security), jessie4.1+dfsg-1+deb8u15fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u1fixed
buster, sid4.9.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.7.3+dfsg-1medium857026
wordpresssourcejessie4.1+dfsg-1+deb8u13mediumDSA-3815-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u14mediumDLA-860-1

Notes

https://wordpress.org/news/2017/03/wordpress-4-7-3-security-and-maintenance-release/
https://github.com/WordPress/WordPress/commit/288cd469396cfe7055972b457eb589cea51ce40e

Search for package or bug name: Reporting problems