CVE-2017-6817

NameCVE-2017-6817
DescriptionIn WordPress before 4.7.3 (wp-includes/embed.php), there is authenticated Cross-Site Scripting (XSS) in YouTube URL Embeds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3815-1
NVD severitylow
Debian Bugs857026

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6fixed
stretch (security)4.7.21+dfsg-0+deb9u1fixed
buster5.0.12+dfsg1-0+deb10u1fixed
buster (security)5.0.14+dfsg1-0+deb10u1fixed
bullseye5.7.1+dfsg1-2fixed
bullseye (security)5.7.3+dfsg1-0+deb11u1fixed
bookworm, sid5.8.1+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcewheezy(not affected)
wordpresssourcejessie4.1+dfsg-1+deb8u13DSA-3815-1
wordpresssource(unstable)4.7.3+dfsg-1857026

Notes

[wheezy] - wordpress <not-affected> (vulnerable code was introduced later)
https://wordpress.org/news/2017/03/wordpress-4-7-3-security-and-maintenance-release/
https://github.com/WordPress/WordPress/commit/419c8d97ce8df7d5004ee0b566bc5e095f0a6ca8

Search for package or bug name: Reporting problems