CVE-2017-6888

NameCVE-2017-6888
DescriptionAn error in the "read_metadata_vorbiscomment_()" function (src/libFLAC/stream_decoder.c) in FLAC version 1.3.2 can be exploited to cause a memory leak via a specially crafted FLAC file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2514-1
Debian Bugs897015

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flac (PTS)buster, buster (security)1.3.2-3+deb10u2fixed
bullseye1.3.3-2+deb11u1fixed
bookworm, sid1.3.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flacsourcestretch1.3.2-2+deb9u1DLA-2514-1
flacsource(unstable)1.3.2-2low897015

Notes

[jessie] - flac <no-dsa> (Minor issue)
[wheezy] - flac <no-dsa> (Minor issue)
https://secuniaresearch.flexerasoftware.com/secunia_research/2017-7/
https://github.com/xiph/flac/commit/4f47b63e9c971e6391590caf00a0f2a5ed612e67 (1.3.3)
https://android.googlesource.com/platform/external/flac/+/4f47b63e9c971e6391590caf00a0f2a5ed612e67

Search for package or bug name: Reporting problems