CVE-2017-6892

NameCVE-2017-6892
DescriptionIn libsndfile version 1.0.28, an error in the "aiff_read_chanmap()" function (aiff.c) can be exploited to cause an out-of-bounds read memory access via a specially crafted AIFF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2418-1, DLA-985-1
NVD severitymedium
Debian Bugs864704

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)stretch1.0.27-3vulnerable
stretch (security)1.0.27-3+deb9u2fixed
buster1.0.28-6fixed
buster (security)1.0.28-6+deb10u1fixed
bookworm, sid, bullseye1.0.31-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesourcewheezy1.0.25-9.1+deb7u3DLA-985-1
libsndfilesourcestretch1.0.27-3+deb9u1DLA-2418-1
libsndfilesource(unstable)1.0.28-1864704

Notes

[jessie] - libsndfile <no-dsa> (Minor issue)
Fixed by: https://github.com/erikd/libsndfile/commit/f833c53cb596e9e1792949f762e0b33661822748

Search for package or bug name: Reporting problems