CVE-2017-6927

NameCVE-2017-6927
DescriptionDrupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1295-1, DSA-4123-1
NVD severitymedium
Debian Bugs756305, 891150

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)stretch7.52-2+deb9u11fixed
stretch (security)7.52-2+deb9u16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7sourcewheezy7.14-2+deb7u17DLA-1295-1
drupal7sourcejessie7.32-1+deb8u10DSA-4123-1
drupal7sourcestretch7.52-2+deb9u2DSA-4123-1
drupal7source(unstable)7.57-1891150
drupal8ITP756305

Notes

https://www.drupal.org/sa-core-2018-001

Search for package or bug name: Reporting problems