CVE-2017-6932

NameCVE-2017-6932
DescriptionDrupal core 7.x versions before 7.57 has an external link injection vulnerability when the language switcher block is used. A similar vulnerability exists in various custom and contributed modules. This vulnerability could allow an attacker to trick users into unwillingly navigating to an external site.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1295-1, DSA-4123-1
NVD severitymedium (attack range: remote)
Debian Bugs891154

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)jessie (security), jessie7.32-1+deb8u12fixed
stretch (security), stretch7.52-2+deb9u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7source(unstable)7.57-1medium891154
drupal7sourcejessie7.32-1+deb8u10mediumDSA-4123-1
drupal7sourcestretch7.52-2+deb9u2mediumDSA-4123-1
drupal7sourcewheezy7.14-2+deb7u17mediumDLA-1295-1

Notes

https://www.drupal.org/sa-core-2018-001

Search for package or bug name: Reporting problems