CVE-2017-6960

NameCVE-2017-6960
DescriptionAn issue was discovered in apng2gif 1.7. There is an integer overflow resulting in a heap-based buffer over-read, related to the load_apng function and the imagesize variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-981-1
NVD severitymedium (attack range: remote)
Debian Bugs854367

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apng2gif (PTS)wheezy1.5-1vulnerable
wheezy (security)1.5-1+deb7u1fixed
jessie1.5-3vulnerable
stretch, buster, sid1.7-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apng2gifsource(unstable)(unfixed)medium854367
apng2gifsourcewheezy1.5-1+deb7u1mediumDLA-981-1

Notes

[stretch] - apng2gif <no-dsa> (Minor issue; can be fixed via point release)
[jessie] - apng2gif <no-dsa> (Minor issue; can be fixed via point release)

Search for package or bug name: Reporting problems