CVE-2017-7161

NameCVE-2017-7161
DescriptionAn issue was discovered in certain Apple products. Safari before 11.0.2 is affected. The issue involves the "WebKit Web Inspector" component. It allows remote attackers to execute arbitrary code via special characters that trigger command injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)jessie2.6.2+dfsg1-4vulnerable
stretch2.18.6-1~deb9u1fixed
buster, sid2.22.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksource(unstable)2.18.6-1unimportant
webkit2gtksourcestretch2.18.6-1~deb9u1medium

Notes

https://webkitgtk.org/security/WSA-2018-0002.html
Not covered by security support

Search for package or bug name: Reporting problems