CVE-2017-7203

NameCVE-2017-7203
DescriptionA Cross-Site Scripting (XSS) was discovered in ZoneMinder before 1.30.2. The vulnerability exists due to insufficient filtration of user-supplied data (postLoginQuery) passed to the "ZoneMinder-master/web/skins/classic/views/js/postlogin.js.php" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs858329

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zoneminder (PTS)wheezy1.25.0-4vulnerable
wheezy (security)1.25.0-4+deb7u2vulnerable
buster, sid1.30.4+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zonemindersource(unstable)1.30.4+dfsg-1medium858329

Notes

[wheezy] - zoneminder <no-dsa> (Minor issue)
https://github.com/ZoneMinder/ZoneMinder/issues/1797
Fixed in 1.30.2 upstream.

Search for package or bug name: Reporting problems