CVE-2017-7246

NameCVE-2017-7246
DescriptionStack-based buffer overflow in the pcre32_copy_substring function in pcre_get.c in libpcre1 in PCRE 8.40 allows remote attackers to cause a denial of service (WRITE of size 268) or possibly have unspecified other impact via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs858679

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)wheezy1:8.30-5fixed
jessie2:8.35-3.3+deb8u4vulnerable
stretch2:8.39-3vulnerable
buster2:8.39-4vulnerable
sid2:8.39-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3source(unstable)(unfixed)unimportant858679
pcre3sourcewheezy(not affected)

Notes

[jessie] - pcre3 <no-dsa> (Minor issue; 32bit character support not enabled)
[wheezy] - pcre3 <not-affected> (Vulnerable code not present)
https://bugs.exim.org/show_bug.cgi?id=2057
https://blogs.gentoo.org/ago/2017/03/20/libpcre-two-stack-based-buffer-overflow-write-in-pcre32_copy_substring-pcre_get-c/
pcre32 support enabled only in pcre3/1:8.35-4
Fixed by: http://vcs.pcre.org/pcre?view=revision&revision=1691 (8.41)

Search for package or bug name: Reporting problems