CVE-2017-7300

NameCVE-2017-7300
DescriptionThe Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.28, has an aout_link_add_symbols function in bfd/aoutx.h that is vulnerable to a heap-based buffer over-read (off-by-one) because of an incomplete check for invalid string offsets while loading symbols, leading to a GNU linker (ld) program crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
binutils (PTS)wheezy2.22-8+deb7u2vulnerable
wheezy (security)2.22-8+deb7u3vulnerable
jessie2.25-5+deb8u1vulnerable
stretch2.28-5fixed
buster, sid2.29.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
binutilssource(unstable)2.27.51.20161212-1medium

Notes

[jessie] - binutils <ignored> (Minor issue)
[wheezy] - binutils <no-dsa> (Minor issue)
https://sourceware.org/bugzilla/show_bug.cgi?id=20909

Search for package or bug name: Reporting problems