CVE-2017-7378

NameCVE-2017-7378
DescriptionThe PoDoFo::PdfPainter::ExpandTabs function in PdfPainter.cpp in PoDoFo 0.9.5 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-968-1
NVD severitymedium
Debian Bugs859330

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpodofo (PTS)jessie0.9.0-1.2vulnerable
stretch0.9.4-6fixed
bullseye, sid, buster0.9.6+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpodofosource(unstable)0.9.4-6859330
libpodofosourcewheezy0.9.0-1.1+deb7u2DLA-968-1

Notes

[jessie] - libpodofo <no-dsa> (Minor issue)
http://www.openwall.com/lists/oss-security/2017/04/01/1
upstream commit: http://sourceforge.net/p/podofo/code/1847

Search for package or bug name: Reporting problems