CVE-2017-7418

NameCVE-2017-7418
DescriptionProFTPD before 1.3.5e and 1.3.6 before 1.3.6rc5 controls whether the home directory of a user could contain a symbolic link through the AllowChrootSymlinks configuration option, but checks only the last path component when enforcing AllowChrootSymlinks. Attackers with local access could bypass the AllowChrootSymlinks control by replacing a path component (other than the last one) with a symbolic link. The threat model includes an attacker who is not granted full filesystem access by a hosting provider, but can reconfigure the home directory of an FTP user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs859592

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
proftpd-dfsg (PTS)stretch1.3.5b-4+deb9u5fixed
stretch (security)1.3.5e+r1.3.5b-4+deb9u2fixed
buster1.3.6-4+deb10u5fixed
buster (security)1.3.6-4+deb10u4fixed
bullseye, sid1.3.7a-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
proftpd-dfsgsourcejessie1.3.5-1.1+deb8u2
proftpd-dfsgsource(unstable)1.3.5b-4low859592

Notes

[wheezy] - proftpd-dfsg <no-dsa> (Minor issue)
http://bugs.proftpd.org/show_bug.cgi?id=4295
https://github.com/proftpd/proftpd/commit/ecff21e0d0e84f35c299ef91d7fda088e516d4ed
https://github.com/proftpd/proftpd/commit/f59593e6ff730b832dbe8754916cb5c821db579f

Search for package or bug name: Reporting problems