CVE-2017-7480

NameCVE-2017-7480
Descriptionrkhunter versions before 1.4.4 are vulnerable to file download over insecure channel when doing mirror update resulting into potential remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1039-1
NVD severityhigh
Debian Bugs866677

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rkhunter (PTS)stretch1.4.2-6+deb9u1fixed
buster1.4.6-5fixed
bullseye1.4.6-9fixed
bookworm, sid1.4.6-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rkhuntersourcewheezy1.4.0-1+deb7u1DLA-1039-1
rkhuntersourcejessie1.4.2-0.4+deb8u1
rkhuntersourcestretch1.4.2-6+deb9u1
rkhuntersource(unstable)1.4.4-1866677

Notes

https://www.openwall.com/lists/oss-security/2017/06/29/2
http://rkhunter.cvs.sourceforge.net/viewvc/rkhunter/rkhunter/files/rkhunter?r1=1.549&r2=1.550&view=patch

Search for package or bug name: Reporting problems