CVE-2017-7493

NameCVE-2017-7493
DescriptionQuick Emulator (Qemu) built with the VirtFS, host directory sharing via Plan 9 File System(9pfs) support, is vulnerable to an improper access control issue. It could occur while accessing virtfs metadata files in mapped-file security mode. A guest user could use this flaw to escalate their privileges inside guest.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1035-1, DLA-1497-1, DLA-965-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u7fixed
stretch1:2.8+dfsg-6+deb9u4fixed
stretch (security)1:2.8+dfsg-6+deb9u5fixed
buster, sid1:2.12+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.8+dfsg-6medium
qemusourcejessie1:2.1+dfsg-12+deb8u7mediumDLA-1497-1
qemusourcewheezy1.1.2+dfsg-6+deb7u22mediumDLA-1035-1
qemu-kvmsource(unstable)(unfixed)medium
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u22mediumDLA-965-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1451709
https://lists.gnu.org/archive/html/qemu-devel/2017-05/msg03663.html

Search for package or bug name: Reporting problems