CVE-2017-7494

NameCVE-2017-7494
DescriptionSamba since version 3.5.0 is vulnerable to remote code execution vulnerability, allowing a malicious client to upload a shared library to a writable share, and then cause the server to load and execute it.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-951-1, DSA-3860-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)wheezy2:3.6.6-6+deb7u7vulnerable
wheezy (security)2:3.6.6-6+deb7u15fixed
jessie, jessie (security)2:4.2.14+dfsg-0+deb8u9fixed
stretch, stretch (security)2:4.5.12+dfsg-2+deb9u1fixed
buster, sid2:4.7.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.5.8+dfsg-2high
sambasourcejessie2:4.2.14+dfsg-0+deb8u6highDSA-3860-1
sambasourcewheezy2:3.6.6-6+deb7u13highDLA-951-1

Notes

https://www.samba.org/samba/security/CVE-2017-7494.html

Search for package or bug name: Reporting problems