CVE-2017-7501

NameCVE-2017-7501
DescriptionIt was found that versions of rpm before 4.13.0.2 use temporary files with predictable names when installing an RPM. An attacker with ability to write in a directory where files will be installed could create symbolic links to an arbitrary location and modify content, and possibly permissions to arbitrary files, which could be used for denial of service or possibly privilege escalation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rpm (PTS)wheezy, wheezy (security)4.10.0-5+deb7u2vulnerable
jessie4.11.3-1.1vulnerable
stretch4.12.0.2+dfsg1-2vulnerable
buster, sid4.14.0+dfsg1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rpmsource(unstable)(unfixed)unimportant

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1452133
Not supported for installations in Debian (and an unprivileged attacker would not have permissions for systems directories anyway)

Search for package or bug name: Reporting problems