CVE-2017-7511

NameCVE-2017-7511
Descriptionpoppler since version 0.17.3 has been vulnerable to NULL pointer dereference in pdfunite triggered by specially crafted documents.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs863759

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)buster0.71.0-5fixed
buster (security)0.71.0-5+deb10u1fixed
bullseye20.09.0-3.1fixed
bullseye (security)20.09.0-3.1+deb11u1fixed
bookworm, sid22.08.0-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.57.0-2unimportant863759

Notes

https://bugs.freedesktop.org/show_bug.cgi?id=101149
https://bugs.freedesktop.org/show_bug.cgi?id=101153
Fixed by: https://cgit.freedesktop.org/poppler/poppler/commit/?id=5c9b08a875b07853be6c44e43ff5f7f059df666a
Crash in CLI tool, no security implications

Search for package or bug name: Reporting problems