CVE-2017-7522

NameCVE-2017-7522
DescriptionOpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)wheezy2.2.1-8+deb7u3fixed
wheezy (security)2.2.1-8+deb7u5fixed
jessie (security), jessie2.3.4-5+deb8u2fixed
stretch2.4.0-6+deb9u2vulnerable
stretch (security)2.4.0-6+deb9u1vulnerable
buster2.4.4-1fixed
sid2.4.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsource(unstable)2.4.3-1unimportant
openvpnsourcejessie(not affected)
openvpnsourcewheezy(not affected)

Notes

[jessie] - openvpn <not-affected> (x509-track implemented in 2.4.0)
[wheezy] - openvpn <not-affected> (x509-track implemented in 2.4.0)
Fixed by: https://github.com/OpenVPN/openvpn/commit/426392940c
https://community.openvpn.net/openvpn/wiki/VulnerabilitiesFixedInOpenVPN243
http://www.openwall.com/lists/oss-security/2017/06/21/6
In Debian openvpn is compiled against OpenSSL, thus even affected
code present.

Search for package or bug name: Reporting problems