DescriptionOpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to denial-of-service by authenticated remote attacker via sending a certificate with an embedded NULL character.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)stretch2.4.0-6+deb9u3vulnerable
stretch (security)2.4.0-6+deb9u1vulnerable
bookworm, sid, bullseye2.5.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsourcewheezy(not affected)
openvpnsourcejessie(not affected)


[jessie] - openvpn <not-affected> (x509-track implemented in 2.4.0)
[wheezy] - openvpn <not-affected> (x509-track implemented in 2.4.0)
Fixed by:
In Debian openvpn is compiled against OpenSSL, thus even affected
code present.

Search for package or bug name: Reporting problems