CVE-2017-7544

NameCVE-2017-7544
Descriptionlibexif through 0.6.21 is vulnerable to out-of-bounds heap read vulnerability in exif_data_save_data_entry function in libexif/exif-data.c caused by improper length computation of the allocated data of an ExifMnote entry which can cause denial-of-service or possibly information disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2214-1
NVD severitymedium
Debian Bugs876466

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libexif (PTS)jessie, stretch0.6.21-2vulnerable
jessie (security)0.6.21-2+deb8u3fixed
stretch (security)0.6.21-2+deb9u1vulnerable
buster, buster (security)0.6.21-5.1+deb10u1fixed
bullseye0.6.21-8fixed
sid0.6.21-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libexifsource(unstable)0.6.21-2.1876466
libexifsourcejessie0.6.21-2+deb8u2DLA-2214-1

Notes

[stretch] - libexif <no-dsa> (Minor issue)
[wheezy] - libexif <no-dsa> (Minor issue)
https://sourceforge.net/p/libexif/bugs/130/

Search for package or bug name: Reporting problems