CVE-2017-7557

NameCVE-2017-7557
Descriptiondnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs872854

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dnsdist (PTS)stretch1.1.0-2+deb9u1fixed
buster1.3.3-3fixed
bullseye1.5.1-3fixed
bookworm, sid1.7.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dnsdistsourcestretch1.1.0-2+deb9u1
dnsdistsource(unstable)1.2.0-1low872854

Notes

https://dnsdist.org/security-advisories/powerdns-advisory-for-dnsdist-2017-02.html
https://downloads.powerdns.com/patches/2017-02

Search for package or bug name: Reporting problems