CVE-2017-7585

NameCVE-2017-7585
DescriptionIn libsndfile before 1.0.28, an error in the "flac_buffer_copy()" function (flac.c) can be exploited to cause a stack-based buffer overflow via a specially crafted FLAC file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-928-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)wheezy1.0.25-5vulnerable
wheezy (security)1.0.25-9.1+deb7u4fixed
jessie1.0.25-9.1+deb8u1vulnerable
stretch1.0.27-3fixed
buster, sid1.0.28-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesource(unstable)1.0.27-2medium
libsndfilesourcewheezy1.0.25-9.1+deb7u1mediumDLA-928-1

Notes

[jessie] - libsndfile <no-dsa> (Minor issue)
https://github.com/erikd/libsndfile/commit/60b234301adf258786d8b90be5c1d437fc8799e0
https://secuniaresearch.flexerasoftware.com/secunia_research/2017-4/
1.0.27-2 in unstable contain fix_bufferoverflows.patch meant to address this issue
https://sources.debian.net/data/main/libs/libsndfile/1.0.27-2/debian/patches/fix_bufferoverflows.patch

Search for package or bug name: Reporting problems