CVE-2017-7599

NameCVE-2017-7599
DescriptionLibTIFF 4.0.7 has an "outside the range of representable values of type short" undefined behavior issue, which might allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-911-1, DLA-912-1, DSA-3844-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)wheezy4.0.2-6+deb7u5vulnerable
wheezy (security)4.0.2-6+deb7u14fixed
jessie4.0.3-12.3+deb8u2vulnerable
jessie (security)4.0.3-12.3+deb8u3fixed
buster, stretch, sid4.0.8-2fixed
tiff3 (PTS)wheezy3.9.6-11vulnerable
wheezy (security)3.9.6-11+deb7u6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)4.0.7-6medium
tiffsourcejessie4.0.3-12.3+deb8u3mediumDSA-3844-1
tiffsourcewheezy4.0.2-6+deb7u12mediumDLA-911-1
tiff3source(unstable)(unfixed)medium
tiff3sourcewheezy3.9.6-11+deb7u5mediumDLA-912-1

Notes

https://github.com/vadz/libtiff/commit/3144e57770c1e4d26520d8abee750f8ac8b75490
https://blogs.gentoo.org/ago/2017/04/01/libtiff-multiple-ubsan-crashes

Search for package or bug name: Reporting problems