CVE-2017-7606

NameCVE-2017-7606
Descriptioncoders/rle.c in ImageMagick 7.0.5-4 has an "outside the range of representable values of type unsigned char" undefined behavior issue, which might allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-902-1, DSA-3863-1
NVD severitymedium (attack range: remote)
Debian Bugs859771

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie (security), jessie8:6.8.9.9-5+deb8u11fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u3fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-4medium859771
imagemagicksourcejessie8:6.8.9.9-5+deb8u9mediumDSA-3863-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u13mediumDLA-902-1

Notes

https://github.com/ImageMagick/ImageMagick/issues/415
https://blogs.gentoo.org/ago/2017/04/02/imagemagick-undefined-behavior-in-codersrle-c/

Search for package or bug name: Reporting problems