CVE-2017-7608

NameCVE-2017-7608
DescriptionThe ebl_object_note_type_name function in eblobjnotetypename.c in elfutils 0.168 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted ELF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1689-1
NVD severitymedium (attack range: remote)
Debian Bugs859995

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
elfutils (PTS)jessie0.159-4.2vulnerable
jessie (security)0.159-4.2+deb8u1fixed
stretch0.168-1fixed
bullseye, sid, buster0.176-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
elfutilssource(unstable)0.168-1medium859995
elfutilssourcejessie0.159-4.2+deb8u1mediumDLA-1689-1

Notes

[wheezy] - elfutils <no-dsa> (Minor issue)
https://sourceware.org/bugzilla/show_bug.cgi?id=21300
https://blogs.gentoo.org/ago/2017/04/03/elfutils-heap-based-buffer-overflow-in-ebl_object_note_type_name-eblobjnotetypename-c/
https://sourceware.org/git/?p=elfutils.git;a=commit;h=b0b58c5e0b34e54194aa042f2310af58ee7de603

Search for package or bug name: Reporting problems