CVE-2017-7654

NameCVE-2017-7654
DescriptionIn Eclipse Mosquitto 1.4.15 and earlier, a Memory Leak vulnerability was found within the Mosquitto Broker. Unauthenticated clients can send crafted CONNECT packets which could cause a denial of service in the Mosquitto Broker.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1525-1, DSA-4325-1
NVD severitymedium (attack range: remote)
Debian Bugs911265

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mosquitto (PTS)jessie1.3.4-2+deb8u1vulnerable
jessie (security)1.3.4-2+deb8u3fixed
stretch (security), stretch1.4.10-3+deb9u2fixed
buster1.5.4-1fixed
sid1.5.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mosquittosource(unstable)1.5.4-1medium911265
mosquittosourcejessie1.3.4-2+deb8u3mediumDLA-1525-1
mosquittosourcestretch1.4.10-3+deb9u2mediumDSA-4325-1

Notes

https://bugs.eclipse.org/bugs/show_bug.cgi?id=533493
https://github.com/eclipse/mosquitto/commit/51ec5601c2ec523bf2973fdc1eca77335eafb8de

Search for package or bug name: Reporting problems