CVE-2017-7659

NameCVE-2017-7659
DescriptionA maliciously constructed HTTP/2 request could cause mod_http2 2.4.24, 2.4.25 to dereference a NULL pointer and crash the server process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)wheezy2.2.22-13+deb7u6fixed
wheezy (security)2.2.22-13+deb7u12fixed
jessie2.4.10-10+deb8u9fixed
jessie (security)2.4.10-10+deb8u11fixed
stretch (security), stretch2.4.25-3+deb9u3fixed
buster, sid2.4.27-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.25-4medium
apache2sourcejessie(not affected)
apache2sourcestretch2.4.25-3+deb9u1medium
apache2sourcewheezy(not affected)

Notes

[jessie] - apache2 <not-affected> (Vulnerable code not present)
[wheezy] - apache2 <not-affected> (Vulnerable code not present)
HTTP/2 support introduced in 2.4.17
http://www.openwall.com/lists/oss-security/2017/06/19/5

Search for package or bug name: Reporting problems