CVE-2017-7675

NameCVE-2017-7675
DescriptionThe HTTP/2 implementation in Apache Tomcat 9.0.0.M1 to 9.0.0.M21 and 8.5.0 to 8.5.15 bypassed a number of security checks that prevented directory traversal attacks. It was therefore possible to bypass security constraints using a specially crafted URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs802312

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)wheezy6.0.45+dfsg-1~deb7u1fixed
wheezy (security)6.0.45+dfsg-1~deb7u5fixed
jessie (security), jessie6.0.45+dfsg-1~deb8u1fixed
tomcat7 (PTS)wheezy7.0.28-4+deb7u4fixed
wheezy (security)7.0.28-4+deb7u15fixed
jessie (security), jessie7.0.56-3+deb8u11fixed
stretch7.0.75-1fixed
buster, sid7.0.78-1fixed
tomcat8 (PTS)jessie8.0.14-1+deb8u10fixed
jessie (security)8.0.14-1+deb8u11fixed
stretch (security), stretch8.5.14-1+deb9u2fixed
buster, sid8.5.23-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat6source(unstable)(not affected)
tomcat7source(unstable)(not affected)
tomcat8source(unstable)8.5.16-1medium
tomcat8sourcejessie(not affected)
tomcat8sourcestretch8.5.14-1+deb9u2medium
tomcat9ITP802312

Notes

[jessie] - tomcat8 <not-affected> (Only affects 8.5.0 to 8.5.15)
- tomcat7 <not-affected> (Only affects Tomcat 8.5.x and 9.x series; vulnerable code not present)
- tomcat6 <not-affected> (Only affects Tomcat 8.5.x and 9.x series; vulnerable code not present)
Fixed by: http://svn.apache.org/r1796091 (8.5.x)
https://bz.apache.org/bugzilla/show_bug.cgi?id=61120

Search for package or bug name: Reporting problems