CVE-2017-7698

NameCVE-2017-7698
DescriptionA Use After Free in the pdf2swf part of swftools 0.9.2 and earlier allows remote attackers to execute arbitrary code via a malformed PDF document, possibly a consequence of an error in Gfx.cc in Xpdf 3.02.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
swftools (PTS)stretch0.9.2+git20130725-4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
swftoolssource(unstable)0.9.2+ds1-2

Notes

https://github.com/matthiaskramm/swftools/pull/19
Vulnerable code removed with the 0.9.2+dfs1-2 upload

Search for package or bug name: Reporting problems