CVE-2017-7742

NameCVE-2017-7742
DescriptionIn libsndfile before 1.0.28, an error in the "flac_buffer_copy()" function (flac.c) can be exploited to cause a segmentation violation (with read memory access) via a specially crafted FLAC file during a resample attempt, a similar issue to CVE-2017-7585.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-928-1
NVD severitymedium (attack range: remote)
Debian Bugs860255

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)wheezy1.0.25-5vulnerable
wheezy (security)1.0.25-9.1+deb7u3fixed
jessie1.0.25-9.1+deb8u1vulnerable
buster, stretch1.0.27-3fixed
sid1.0.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesource(unstable)1.0.27-3medium860255
libsndfilesourcewheezy1.0.25-9.1+deb7u1mediumDLA-928-1

Notes

[jessie] - libsndfile <no-dsa> (Minor issue)
Fixed by: https://github.com/erikd/libsndfile/commit/60b234301adf258786d8b90be5c1d437fc8799e0
https://blogs.gentoo.org/ago/2017/04/11/libsndfile-invalid-memory-read-and-invalid-memory-write-in/

Search for package or bug name: Reporting problems