CVE-2017-7752

NameCVE-2017-7752
DescriptionA use-after-free vulnerability during specific user interactions with the input method editor (IME) in some languages due to how events are handled. This results in a potentially exploitable crash but would require specific user interaction to trigger. This vulnerability affects Firefox < 54, Firefox ESR < 52.2, and Thunderbird < 52.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1007-1, DLA-991-1, DSA-3881-1, DSA-3918-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid62.0-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)52.9.0esr-1~deb8u1fixed
stretch52.9.0esr-1~deb9u1fixed
stretch (security)60.2.0esr-1~deb9u2fixed
buster52.9.0esr-1fixed
sid60.2.0esr-1fixed
icedove (PTS)jessie1:52.3.0-4~deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)54.0-1medium
firefox-esrsource(unstable)52.2.0esr-1medium
firefox-esrsourcejessie52.2.0esr-1~deb8u1mediumDSA-3881-1
firefox-esrsourcestretch52.2.0esr-1~deb9u1mediumDSA-3881-1
firefox-esrsourcewheezy52.2.0esr-1~deb7u1mediumDLA-991-1
icedovesource(unstable)1:52.2.0-1medium
icedovesourcejessie1:52.2.1-4~deb8u1mediumDSA-3918-1
icedovesourcestretch1:52.2.1-4~deb9u1mediumDSA-3918-1
icedovesourcewheezy1:52.2.1-1~deb7u1mediumDLA-1007-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2017-15/#CVE-2017-7752
https://www.mozilla.org/en-US/security/advisories/mfsa2017-16/#CVE-2017-7752
https://www.mozilla.org/en-US/security/advisories/mfsa2017-17/#CVE-2017-7752

Search for package or bug name: Reporting problems