CVE-2017-7828

NameCVE-2017-7828
DescriptionA use-after-free vulnerability can occur when flushing and resizing layout because the "PressShell" object has been freed while still in use. This results in a potentially exploitable crash during these operations. This vulnerability affects Firefox < 57, Firefox ESR < 52.5, and Thunderbird < 52.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1172-1, DLA-1199-1, DSA-4035-1, DSA-4061-1, DSA-4075-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid63.0.3-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)60.3.0esr-1~deb8u1fixed
stretch (security), stretch60.3.0esr-1~deb9u1fixed
buster60.3.0esr-1fixed
sid60.4.0esr-1fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1fixed
jessie (security)1:60.3.0-1~deb8u1fixed
stretch1:60.2.1-2~deb9u1fixed
stretch (security)1:60.3.0-1~deb9u1fixed
buster, sid1:60.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)57.0-1high
firefox-esrsource(unstable)52.5.0esr-1high
firefox-esrsourcejessie52.5.0esr-1~deb8u1highDSA-4035-1
firefox-esrsourcestretch52.5.0esr-1~deb9u1highDSA-4035-1
firefox-esrsourcewheezy52.5.0esr-1~deb7u1highDLA-1172-1
thunderbirdsource(unstable)1:52.5.0-1high
thunderbirdsourcejessie1:52.5.2-2~deb8u1highDSA-4075-1
thunderbirdsourcestretch1:52.5.2-2~deb9u1highDSA-4075-1
thunderbirdsourcewheezy1:52.5.0-1~deb7u1highDLA-1199-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2017-24/#CVE-2017-7828
https://www.mozilla.org/en-US/security/advisories/mfsa2017-25/#CVE-2017-7828
https://www.mozilla.org/en-US/security/advisories/mfsa2017-26/#CVE-2017-7828

Search for package or bug name: Reporting problems