CVE-2017-7830

NameCVE-2017-7830
DescriptionThe Resource Timing API incorrectly revealed navigations in cross-origin iframes. This is a same-origin policy violation and could allow for data theft of URLs loaded by users. This vulnerability affects Firefox < 57, Firefox ESR < 52.5, and Thunderbird < 52.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1172-1, DLA-1199-1, DSA-4035-1, DSA-4061-1, DSA-4075-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid105.0.1-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1fixed
buster (security)102.3.0esr-1~deb10u2fixed
bullseye91.13.0esr-1~deb11u1fixed
bullseye (security)102.3.0esr-1~deb11u1fixed
bookworm, sid102.3.0esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:102.3.0-1~deb10u1fixed
bullseye1:91.13.0-1~deb11u1fixed
bullseye (security)1:102.3.0-1~deb11u1fixed
bookworm1:102.3.1-1fixed
sid1:102.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)57.0-1
firefox-esrsourcewheezy52.5.0esr-1~deb7u1DLA-1172-1
firefox-esrsourcejessie52.5.0esr-1~deb8u1DSA-4035-1
firefox-esrsourcestretch52.5.0esr-1~deb9u1DSA-4035-1
firefox-esrsource(unstable)52.5.0esr-1
thunderbirdsourcewheezy1:52.5.0-1~deb7u1DLA-1199-1
thunderbirdsourcejessie1:52.5.2-2~deb8u1DSA-4075-1
thunderbirdsourcestretch1:52.5.2-2~deb9u1DSA-4075-1
thunderbirdsource(unstable)1:52.5.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2017-24/#CVE-2017-7830
https://www.mozilla.org/en-US/security/advisories/mfsa2017-25/#CVE-2017-7830
https://www.mozilla.org/en-US/security/advisories/mfsa2017-26/#CVE-2017-7830

Search for package or bug name: Reporting problems