CVE-2017-7942

NameCVE-2017-7942
DescriptionThe ReadAVSImage function in avs.c in ImageMagick 7.0.5-4 allows remote attackers to consume an amount of available memory via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs860735

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bookworm, sid, bullseye8:6.9.11.60+dfsg-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcewheezy(not affected)
imagemagicksourcejessie(not affected)
imagemagicksource(unstable)8:6.9.7.4+dfsg-6low860735

Notes

[jessie] - imagemagick <not-affected> (Vulnerable code not present, does not use pixel_info yet)
[wheezy] - imagemagick <not-affected> (Vulnerable code not present, does not use pixel_info yet)
https://github.com/ImageMagick/ImageMagick/issues/429

Search for package or bug name: Reporting problems