CVE-2017-7948

NameCVE-2017-7948
DescriptionInteger overflow in the mark_curve function in Artifex Ghostscript 9.21 allows remote attackers to cause a denial of service (out-of-bounds write and application crash) or possibly have unspecified other impact via a crafted PostScript document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie (security), jessie9.06~dfsg-2+deb8u6fixed
stretch (security), stretch9.20~dfsg-3.2+deb9u1vulnerable
buster, sid9.22~dfsg-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.22~dfsg-1unimportant
ghostscriptsourcejessie(not affected)
ghostscriptsourcewheezy(not affected)

Notes

[jessie] - ghostscript <not-affected> (Vulnerable code not present)
[wheezy] - ghostscript <not-affected> (Vulnerable code not present)
https://bugs.ghostscript.com/show_bug.cgi?id=697762
Fixed by: http://git.ghostscript.com/?p=ghostpdl.git;h=8210a2864372723b49c526e2b102fdc00c9c4699
edgebuffer scan converter was made default only in: http://git.ghostscript.com/?p=ghostpdl.git;h=dd5da2cb3e08398ac6d86598b36b00994d058308
But the vulnerable code via base/gxscan.c, a new scan converter introduced in 9.20 is present.

Search for package or bug name: Reporting problems