CVE-2017-8054

NameCVE-2017-8054
DescriptionThe function PdfPagesTree::GetPageNodeFromArray in PdfPageTree.cpp:464 in PoDoFo 0.9.5 allows remote attackers to cause a denial of service (infinite recursion and application crash) via a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs860995

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpodofo (PTS)jessie0.9.0-1.2vulnerable
stretch0.9.4-6vulnerable
buster, sid0.9.6+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpodofosource(unstable)0.9.5-9medium860995

Notes

[stretch] - libpodofo <no-dsa> (Minor issue)
[jessie] - libpodofo <no-dsa> (Minor issue)
[wheezy] - libpodofo <no-dsa> (Minor issue)
The motivation for no-dsa in wheezy is that there are no known
services that use this library (apart from desktop applications)
and the worst case is a DoS.
http://qwertwwwe.github.io/2017/04/22/PoDoFo-0-9-5-allows-remote-attackers-to-cause-a-denial-of-service-infinit-loop/
PoC: https://github.com/qwertwwwe/PoC/blob/master/podofo/PoC
upstream commit: https://sourceforge.net/p/podofo/code/1872
partially reverted in: https://sourceforge.net/p/podofo/code/1881
... and re-fixed in: https://sourceforge.net/p/podofo/code/1882
and https://sourceforge.net/p/podofo/code/1883

Search for package or bug name: Reporting problems