CVE-2017-8068

NameCVE-2017-8068
Descriptiondrivers/net/usb/pegasus.c in the Linux kernel 4.9.x before 4.9.11 interacts incorrectly with the CONFIG_VMAP_STACK option, which allows local users to cause a denial of service (system crash or memory corruption) or possibly have unspecified other impact by leveraging use of more than one virtual page for a DMA scatterlist.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)
Debian Bugs852556

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1fixed
wheezy (security)3.2.96-3fixed
jessie3.16.51-2fixed
jessie (security)3.16.51-3+deb8u1fixed
stretch4.9.65-3fixed
stretch (security)4.9.65-3+deb9u2fixed
buster4.14.7-1fixed
sid4.14.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.9.10-1high852556
linuxsourcejessie(not affected)
linuxsourcewheezy(not affected)

Notes

[jessie] - linux <not-affected> (Introduced in 4.9-rc1 in combination with VMAP_STACK)
[wheezy] - linux <not-affected> (Introduced in 4.9-rc1 in combination with VMAP_STACK)
Fixed by: https://git.kernel.org/linus/5593523f968bc86d42a035c6df47d5e0979b5ace

Search for package or bug name: Reporting problems